Zero to Dapp Tutorial and Windows Operating System


#1

Hi.

I’m a beginner in this. I was trying to follow the tutorial “Zero to Dapp”.

I think there is an incoherence in there. A Mac system seems to be a prerrequisite (see “# 2 Learn about the Blockstack platform”), when in “# 1 About DApps and App Mining” they say “Anyone with access to a Windows, Mac, or Linux computer and some familiarity with a command line should be able to follow along.”

These are those paragraphs:

1 About DApps and App Mining

. . .
### Skills you need to follow this tutorial
This tutorial is written for developers and others who want to learn about DApps and how the Blockstack ecosystem supports their development. As a result, the target audience is intentionally broad. Anyone with access to a Windows, Mac, or Linux computer and some familiarity with a command line should be able to follow along.

2 Learn about the Blockstack platform

. . .
Get prerequisites and set up your environment

To follow the procedures in the rest of this tutorial, you need the following:

A Blockstack ID (identity) to test your Animal Kingdom.
Access to **the Mac terminal window** and some familiarity with the command line it provides.
An installation of the XCode command-line tools to support Node Package Manager (npm)
The Node Package Manager package manager.

Follow the procedures in this section to install these components.
. . .

Then, can I follow this tutorial with (just) a Windows Computer?

Thanks a lot.


#2

@felixium.id.blockstack Right now, the first release of the tutorial assumes a Mac/Linux environment. The parts that are Windows specific are in the NPM installation which is a bit more involved on Windows. If you install NPM on your system, you can follow the tutorial. I tested but have not written up the specific steps on Windows. You can follow the Windows installation instructions here.

And you are absolutely correct we meed a Windows version. I have planned on doing that, the issue was not public, you can find it here:

My expectation is that this issue will be closed by the first week in January.


#3

Hello.

Now, when I try “npm install”, I get this error:

C:\z_USERS\Felix_1\zz_xTEMAS\BlockStack\animal-kingdom-master>npm install

tiny-secp256k1@1.0.1 install C:\z_USERS\Felix_1\zz_xTEMAS\BlockStack\animal-kingdom-master\node_mo
dules\tiny-secp256k1
node-gyp rebuild

C:\z_USERS\Felix_1\zz_xTEMAS\BlockStack\animal-kingdom-master\node_modules\tiny-secp256k1>if not def
ined npm_config_node_gyp (node “C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle
node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Program Files\n
odejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at PythonFinder.failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modul
es\node-gyp\lib\configure.js:484:19)
gyp ERR! stack at PythonFinder. (C:\Program Files\nodejs\node_modules\npm\node_module
s\node-gyp\lib\configure.js:509:16)
gyp ERR! stack at C:\Program Files\nodejs\node_modules\npm\node_modules\graceful-fs\polyfills.js
:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:154:21)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm
\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\z_USERS\Felix_1\zz_xTEMAS\BlockStack\animal-kingdom-master\node_modules\tiny-secp256
k1
gyp ERR! node -v v10.14.2
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN animal-kingdom@1.0.0-alpha.2 No repository field.
npm WARN animal-kingdom@1.0.0-alpha.2 No license field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {“os”:
“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! tiny-secp256k1@1.0.1 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the tiny-secp256k1@1.0.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\z_USERS\Felix_1\AppData\Roaming\npm-cache_logs\2018-12-22T06_58_52_963Z-debug.log

C:\z_USERS\Felix_1\zz_xTEMAS\BlockStack\animal-kingdom-master>

Thanks a lot for your help

Félix


#4

@felixium.id.blocksta I’m sorry to hear you are having issues. Windows can be a tricky environment.

Which version of Node.js did you install? When testing this, I installed 11.5.0 and also made sure to install the additional tools.

image

Finally, just to rule out any path issues. I extracted animal-kingdom-master to
C:\animal-kingdom-master

I expect to have a Windows walkthrough published later tomorrow before Christmas.


#5

Update @felixium.id.blocksta unfortunately, I’m running into problems getting the build to minify in Windows 10. Looks like I might not meet my deadline. Debugging this may be a bit longer. You’ll find my issue here:


#6

Zero-to-Dapp instructions for Windows now available. As you work through the tutorial pages which have a “Windows” version appear with a track callout.

So, keep an eye out. The tracks steer you back to the mainline when the OS distinction is no longer necessary.