Oh no! Our servers are receiving too many requests right now. Please try again later


#1

I can’t sign in with blockstack to complete the Token Sale Registration.
My ID: alexa.id
I’ve tried hundreds of times


#2

Hey @1AYP3EB3WhiAagCToGc5,

I just checked your social proofs (you can see them here: https://explorer.blockstack.org/name/alexa.id). It looks like everything is correct on your side.

We just pushed out a new version of the browser (v0.21) that addresses a lot of the things that can cause this particular error message to appear. Can you try downloading it from here and trying one more time? Thanks!


About backups
#3

Thank you very much, I will try your way.

But I have a question.
If I try your new version of the browser, how do I import my ID: alexa.id? I just paid for it.
I tried to empty the browser cache, because of that I couldn’t retrieve the ID I registered last time.
Could you tell me how to login ID on the blockstack browser?
If I don’t know how to retrieve ID, I may not act rashly.

Thanks


#4

Hi jude,
I’ve tried your way, still the same problem.
Blockstack-for-macOS-v0.21.0


#5

Hi @1AYP3EB3WhiAagCToGc5,

If your ID-address is ID-1AYP3EB3WhiAagCToGc5jdi6A1r47M63bM, then you definitely own alexa.id. I discovered today with @guylepage3 that in rare cases, the browser can sometimes take up to a few minutes to “remember” that your name is owned by the given address (we’re investigating why this is happening). If you watch the page for a few minutes, does your username appear?


#6

Yes jude,
My ID problem has been solved, thanks.
But the Registration problem still bothers me(https://blockstack.com/sale-registration)


I’ve tried your new version Blockstack-for-macOS-v0.21.0, still the same problem.


#7

Could it be that register for token sale on blockstack is totally fallen over?
When i click on the button, it appears that nothing happens.
And now it seems that the page doesn’t render at all anymore.

Please advise.
Thanks,
-james


#8

Glad to hear your ID appeared @1AYP3EB3WhiAagCToGc5 !

It’s not that the server has fallen over (as far as we can tell). Most likely it’s something in the web browser. Do you see any error messages in the developer console?


#9

I am facing the exact same problem. Please help!

I’ve been trying everyday for at least a week! Hard refreshed, tried uninstalling and reinstalling - nothing works!

Appreciate if someone could assist. This is my ID - 19dUFKejZ592z8rT98ntpcx19tCUhxNDPh

Thanks.


#10

Hey @jacquemihov,

Thanks for sending your ID-address! I just took a look. Your twitter, hackernews, and github proofs are fine. For your facebook proof, can you add the text Verifying my Blockstack ID is secured with the address 19dUFKejZ592z8rT98ntpcx19tCUhxNDPh to the post? And for your instagram proof, can you change your proof URL to https://www.instagram.com/p/BbGzv2-BzFN/?taken-by=jacquemihov? Thanks!


Been trying for a week - I can’t sign in with blockstack to complete the Token Sale Registration
#11

Hi Jude,

For FB, I’ve added the text as a comment to the original post.

For instagram, I’ve changed the proof url in my blockstack ID page.

Let me know if this works. Thanks.


#12

I am still getting the same messages.


#13

我收到邮件要Coinlist 实名验证,但我不知道到哪儿认证?


#14

I’m having this same problem. Has the server crashed over the weekend?


#15

Hi Jude,

I’m still getting the same error messages. I’ve been trying every single day for a week. Please help.


#16

Same here. Such a pity. I really wanted to register for this ICO


#17

any update for this issue? I am having the same problem.