New releases on Blockstack.js and Blockstack Browser


#1

Hey everyone!

We’re excited to announce that we’ve just published new versions of blockstack.js and the Blockstack Browser.

The biggest addition here is support for the protocol detection mechanisms we use to open the Blockstack Browser from your apps. A long-standing issue is that Firefox and Safari changed their protocol handling mechanisms, so if a user didn’t have the Blockstack Browser and tried to log into a Blockstack app on Safari or Firefox, an error page would show up, and there was nothing they could do.

This is no longer the case, and we believe we’ve settled this across all browsers (including Chromebooks).

To make this work in your app, you need to update blockstack.js to 18.3.0. There are no API changes required, your code should continue to work. If the end-user has the latest version of the Browser installed, the experience will be the smoothest. If they don’t, they’ll still be able to log in just fine, and they won’t see the protocol handler error.

Go check out version 0.35.4 of Blockstack Browser to get it installed. For more information about what else is in this release, see the beta announcement for this version.

By the way, major props to @zone117x, who built these fixes into both the Browser and Blockstack.js. This is an issue that people have been asking about for a while, and Matt was able to figure out some very clever Javascript techniques to get it working!


Evangelist Meeting Minutes - 2.14.2019
pinned #2

unpinned #3