Gaia nginx container not starting

#1

I’m trying to get a Gaia storage hub working on an t2.medium AWS EC2 instance using these instructions. I’m using the blockstack-gaia_hub-ebs-2.5.3-hvm AMI.

I have an elastic IP 54.173.170.105 linked to registered domain www.tcphub.ga.

/etc/environment:

API_KEY=tcphub
DOMAIN=www.tcphub.ga
STAGING=1

docker ps:

CONTAINER ID        IMAGE                                   COMMAND                  CREATED             STATUS              PORTS                    NAMES
bff17d85599f        quay.io/blockstack/gaia-reader:v2.5.3   "node lib/index.js"      30 minutes ago      Up 29 minutes       0.0.0.0:8008->3000/tcp   gaia-reader
85fad1c8bb2f        quay.io/blockstack/gaia-admin:v2.5.3    "docker-entrypoint.s…"   30 minutes ago      Up 29 minutes       0.0.0.0:8009->3000/tcp   gaia-admin
1f4325cd65fd        quay.io/blockstack/gaia-hub:v2.5.3      "docker-entrypoint.s…"   30 minutes ago      Up 29 minutes       0.0.0.0:3000->3000/tcp   gaia-hub

I tried running sudo systemctl restart reset-ssl-certs.service, but it hangs and never returns.

I tried journalctl -xe but get -- No entries --

I looked for logs, but /var/log/nginx did not even exist. I created it and restarted the instance, but still no logs. I get the impression from watching processes that something is hanging in certbot, but without any logs or output I’m not getting any traction troubleshooting the issue.

Any help is much appreciated!