Failed to fetch information about the app requesting authentication error


#1

When I run my Blockstack app on a local npm server and redirect it to my Android app, I get the following error after clicking “Sign in with Blockstack” button in my Android application:
“Failed to fetch information about the app requesting authentication. Please contact the app maintainer to resolve this issue.”

What does it mean? What can be the problem?


#2

You need to run npm server with SSL support on a hosted domain. This tutorial will help you: https://hackernoon.com/how-to-use-bitcoin-based-blockstack-auth-in-your-ios-apps-a4f157230201


#3

Is there any way to solve this issue locally?


#4

i have this issue,too,if you have already slove this problem ,please teach me


#5

I don’t think localhost would work in this case as app URL is important to authenticate a user against. So, let’s suppose you have an xyz application with xyz.com domain name. When you will authenticate a user against your xyz.com app, a tag gets inserted into the profile.json that user owns. It looks like this:

"apps": {
            "https://xyz.com": "https://gaia.blockstack.org/hub/xxxxxxxxxxxxxx/"
          }

and because you own that URL and control the hosting provider, that I guess is the only way to prove the controlling authority of your app.

Another reason to have it hosted is to see the process of auth. When you click on sign in button, it opens browser.blockstack.org in your browser. Once, you are authenticated, browser.blockstack.org needs to send you back to the app but that particular script does not know your app and you can’t edit it (maybe if you host your own copy of that, I haven’t tried doing that), so the browser.blockstack.org sends you back to your hosted server to redirect and open your app on the phone and that server address should be resolvable over the internet.

If you just want to test the auth, you can use the test URLs given in this iOS example as I haven’t seen the android code yet. Caution would be to know that this is just a test server.

While you are using it, make sure the URL scheme of your app has the entry of myblockstackapp as that is what this server recognizes.


#6

I am also going through the same issue. I depllyed it in netlify then also it is showing the same error


#7

I face the same issue. A have a local angular 6 application, started with ng serve and in the angular.json file I have the certificate info.

“sslCert”: “ssl/server.crt”,
“sslKey”: “ssl/server.key”,


#8

Even if you don’t have a hosted backend, you need to add a manifest.json file on a domain with https://example.com/manifest.json


#9

Yes the manifest.json file was not been served well! It is possible to use it with localhost.


#10

Now, do you solve this problem?if you do,please help me beacuse I have same problem thank you


#11

No, I couldn’t solve it. Solutions like ngrok may work, but since I don’t have time to try them, I turn back to the netlify app given in the Android tutorial.


#12

To Configure with keys that point at a production blockstack environment that is managed on the back end as a 'brand(domain). It also supports multiple languages. In the iOS app, present the view controller to display a list of help articles. Select an article. The text of the article is displayed, but see error message ‘Failed to fetch attachments’ appear at the top of the article. I have also done this for Printer in error state.