Error using blockstack dapps


#1

Hi I’m attempting to use some of the blockstack dapps: stealthy, graphite, this forum etc.

Other then this forum I am unable to use any other blockstack dapps. I am able to log in and some even show a landing page (graphite) but when I try and go to other parts of the dapp or some when I try to use at all (stealthy) The screen is just blank and when I open up the console I recieve the message
“Private key must be less than the curve order”

This is the same message for all dapps that don’t work.

Is this a problem with my system Firefox, OSX, or is it something that I’m just missing? Thank you for any and all help also for creating blockstack


#2

Hi @16rrgTntFDG5FmHT1m4Y,

The error you’re seeing (“Private key must be less than the curve order”) happens when decryption fails during the auth process. You will see this error if you’re opening apps and signing in on different browsers.

This is a known issue and a patch for better error handling should be included in the latest version of blockstack.js.