Can't configure blockstack in Lubuntu


#1

When I type blockstack configure in the terminal, this is the response:
Traceback (most recent call last):
File “/usr/local/bin/blockstack”, line 42, in
from blockstack_client.cli import run_cli, exit_with_error
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/init.py”, line 32, in
import rpc
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/rpc.py”, line 97, in
from .wallet import make_wallet
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/wallet.py”, line 47, in
from .backend.crypto.utils import aes_decrypt, aes_encrypt
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/backend/crypto/init.py”, line 22, in
from utils import aes_encrypt, aes_decrypt
File “/usr/local/lib/python2.7/dist-packages/blockstack_client/backend/crypto/utils.py”, line 26, in
import scrypt
File “build/bdist.linux-x86_64/egg/scrypt/init.py”, line 1, in
#!/usr/bin/env python2
File “build/bdist.linux-x86_64/egg/scrypt/scrypt.py”, line 15, in
ImportError: No module named _scrypt

How can I solve this?


#2

Hey @corvalanlara,

Sorry to see you’re getting stuck. Can you try the following?

$ sudo pip uninstall scrypt
$ sudo pip install scrypt

The uninstall command may report an error, but that’s okay. The root of the problem is that the scrypt maintainer has a weird way of packaging it that can sometimes cause this to happen.


#3

Oh my, I can’t believe that was all I needed for this to work. Thanks a lot!