Animal Kingdom Tutorial


#1

Hi,
I have been following the zero to Dapp tutorial step by step. https://docs.blockstack.org/develop/zero_to_dapp_2.html

At this step:

Start the Animal Kingdom DApp running on your workstation by entering:

npm start

I get the following error:

Failed to compile

./src/App.js
Module not found: Can’t resolve ‘blockstack’.

Help please.


#2

Sorry to hear you are having problems. Please rerun the npm install command in the directory. Then, try the npm run again. That should resolve your issue.


#3

Hi Moxie, tried it but the issue with dependencies I guess.

I was running Python 3.7 and got some issue and the message was to use a python version between 2.5 and 3.0 so i downgraded it to python 2.7.

Now am getting some error w.r.t webpack module.

"
babel-loader@7.1.2 requires a peer of webpack@2 || 3 but none is installed. You must install peer dependencies yourself.

npm WARN extract-text-webpack-plugin@3.0.2 requires a peer of webpack@^3.1.0 but none is installed. You must install peer dependencies yourself.

npm WARN file-loader@1.1.5 requires a peer of webpack@^2.0.0 || ^3.0.0 but none is installed. You must install peer dependencies yourself.

npm WARN html-webpack-plugin@2.29.0 requires a peer of webpack@1 || ^2 || ^2.1.0-beta || ^2.2.0-rc || ^3 but none is installed. You must install peer dependencies yourself.

npm WARN sw-precache-webpack-plugin@0.11.4 requires a peer of webpack@^1 || ^2 || ^2.1.0-beta || ^2.2.0-beta || ^3 but none is installed. You must install peer dependencies yourself.

npm WARN webpack-manifest-plugin@1.3.2 requires a peer of webpack@1 || 2 || 3 but none is installed. You must install peer dependencies yourself.

npm WARN animal-kingdom@1.0.0-alpha.2 No repository field.

npm WARN animal-kingdom@1.0.0-alpha.2 No license field."


#4

Hi @MosesSamPaul can you tell me about your workstation environment? What version of the Windows OS are you using?

I’ll run a test on my end and see if I can’t come up with a set of steps you can follow.


#5

Hi @moxiegirl , am using a mac OS mojave v 10.14.2
node v8.11.1
npm 6.3.0

thanks!


#6

The original tutorials were tested with these:

  • Mojave 10.14
  • Node v11.1.0
  • NPM 6.5.0

Are you able to update node/npm or are you locked to these version? Unfortunately, I can’t guarantee support across all versions of npm/node.

The Webpack problem is explained here in Stack Overflow: