An issue with the default storage


#1

I have an issue with not being able to create the default storage or saving my picture. Guessing those two issues are related.

Is there a general problem with Gaia Hub or is it a local problem?

Running the latest Blockstack browser and Chrome.

Kind regards

Nicki


#2

Hi @Nicki

Sorry to hear that you’re having troublem connecting to the default Gaia Hub. Can you see if there are any errors in your Javascript console when you try to upload your photo?


#3

I’m having pretty much the same problem. blockstack keeps asking me to select default storage, but never selects it


#4

somehow it fixed by itself


#5

When I try to upload a picture it says:

2018-02-14T17:42:48.072+0100 ERROR profiles/DefaultProfilePage.js: uploadProfilePhoto: storage is not connected. Doing nothing.

This makes sense since I haven’t been able to get connected to the default storage. When I try to connect I get these error messages.

VM130:1 GET http://localhost:6270/v1/node/ping net::ERR_CONNECTION_REFUSED

2018-02-14T17:45:46.709+0100 ERROR utils/api-utils.js: isCoreApiRunning: problem checking http://localhost:6270/v1/node/ping [TypeError: Failed to fetch]
TypeError: Failed to fetch

VM130:1 OPTIONS http://localhost:6270/v1/wallet/payment_address
net::ERR_CONNECTION_REFUSED

2018-02-14T17:45:46.724+0100 ERROR utils/api-utils.js: isApiPasswordValid: problem checking http://localhost:6270/v1/wallet/payment_address [TypeError: Failed to fetch]
TypeError: Failed to fetch

2018-02-14T17:45:46.726+0100 DEBUG store/sanity/actions.js: isCoreApiPasswordValid? No!

VM130:1 OPTIONS http://localhost:6270/v1/node/drivers/storage/gaia_hub?index=1 net::ERR_CONNECTION_REFUSED

storage#gaiahub:1 Uncaught (in promise) TypeError: Failed to fetch

If I understand it correctly it seems that the VM is trying to connect to something but the connection is refused.

Now what to do :wink:


#6

@Nicki

It looks like the background daemon that the blockstack browser communicates with died. Try closing and restarting the Blockstack system tray application, or restarting your computer.


#7

Tried that and Uninstalled the application for good masseurs without any luck.

But I noticed something in the URL - don’t know if it is relevant but, when I click home the URL that opens the Blockstack browser contains my API password. But when I reaches the option of choosing the default storage the url is as follows (http://localhost:8888/#coreAPIPassword=off&logServerPort=off ) ? don’t know if it is relevant ;D